+ 3
Java 16.2 Practice Math Class. Can someone help me solve that please ? I have no idea how to do it.
For your math class you need a program to calculate the factorial of a number. You're given a program which takes a number as input. Task Complete the program to calculate the factorial of the given number and output it. Sample input 6 Sample output 720 Explanation The factorial of a number is equal to the product of all numbers less than or equal to the given number. The factorial of 6 will be 6*5*4*3*2*1 = 720. Hint Use while loop to calculate the factorial of the number.
5 Answers
+ 3
import java.util.Scanner;
public class Main
{
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int number = scanner.nextInt();
int fact = 1;
//your code goes here
while(number>0){
fact *= number --;
}
System.out.println(fact);
}
}
0
Thank you, it works !
int number = scanner.nextInt();
int fact = 1;
int i = 1;
while(i <= number){
fact*= i;
i++;
}
System.out.println(fact);
0
what is the answer it is not working.
0
The answer
import java.util.Scanner;
public class Main
{
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int number = scanner.nextInt();
int fact = 1;
//your code goes here
while( number >0){
fact *= number --;
}
System.out.println(fact);
}
}
0
You are making a program for a chess tournament, that needs to calculate the points earned by a player.
A win is worth 1 point, while a tie is worth 0.5 points. The given program declares two variables: wins and ties with the corresponding values.
Create a program to calculate and output the points earned by the player.