Land ho
I have been working on this question for awhile. I am over thinking it. I know that for 20 and under its 10 and over 20 the wait goes up by 20 and up by 10 before the next digit divisible by 20. What am I doing wrong? https://code.sololearn.com/cEBEt4vJ03aT/?ref=app The challenge, Land Ho! You are on a large ship and you put down anchor near a beautiful beach. There is a small boat ferrying passengers back and forth, and you get in line for it. How long will you have to wait to get to the beach? You know that 20 people can fit on the boat and each trip to shore takes 10 minutes each way. Task: Determine your wait time if you know the total number of people ahead of you in line. Input Format: An integer that represents the total number of people ahead of you in line. Output Format: An integer that represents the number of minutes that you will have to wait until you are standing on the beach. Sample Input: 15 Sample Output: 10 My attempt: import math people = int(input()) if people <= 20: time = 10 print(time) elif people >= 20 and people < 41: time = 30 print(time) elif people > 41: if people > people % 20 and people >= 41: time = people * 2 time = time / 2 + 10 print(round(int(time), -1)) elif people < people % 20 and people >= 41: time = people * 2 time = time / 2 + 10 print(round(int(time), -1))