Can anyone explain this
Each coffee option has its own number, starting with 0. Write a program that will take a number from the customer as input from the customer and serve the corresponding coffee type. If the customer enters a number that is out of the accepted range, the program should output "Invalid number". Regardless of coffee option result, the program should output "Have a good day" at the end. Sample Input 7 Sample Output Invalid number Have a good day I finished the challenge with if and else : coffee = {1:"Café Latte", 2:"Caffe Americano", 3:"Espresso",4:"Cappuccino", 5:"Macchiato"} choice = int(input ()) if choice == 0: print(coffee [0]) elif choice == 1: print(coffee [1]) elif choice == 2: print(coffee [2]) elif choice == 3: print(coffee [3]) elif choice == 4: print(coffee [4]) else: print ("Invalid number") print("Have a good day") But what is required is that the solver of the problem asks me to solve it using try, expact and the finally How can i do it ??