Help for Fibonacci in Python
"The Fibonacci sequence is one of the most famous formulas in mathematics. Each number in the sequence is the sum of the two numbers that precede it. For example, here is the Fibonacci sequence for 10 numbers, starting from 0: 0,1,1,2,3,5,8,13,21,34. Write a program to take N (variable num in code template) positive numbers as input, and recursively calculate and output the first N numbers of the Fibonacci sequence (starting from 0). Sample Input 6 Sample Output 0 1 1 2 3 5" #my code num = int(input()) def fibonacci(n): #complete the recursive function if n<=1 : return n else : a = 0 b = 1 print(a) print(b) print(end='') for i in range (2, n): c = a+b print (c) print (end='') a = b b = c print (fibonacci (num)) #my output for n = 6 0 1 1 2 3 5 none <<< why none is printed ?