+ 2
52.2 Practice - How Much Vroom?
You are a supercar engineer and currently setting the engine's horsepower. Complete the given program by completing methods to set and get the horsepower of the car object in order to output it. The program should warn "Too much" if the inputted horsepower is above 800. Sample Input 950 Sample Output Too much 950 *You should use the if statement directly inside the setter function. My code as below, tried many times, it says “x not declared”. Please help.
7 Respostas
+ 4
#include <iostream>
using namespace std;
//class definition
class Car{
//private area
private:
int horsepowers;
//public area
public:
//complete the setter function
void setHorsepowers(int x){
horsepowers = x;
if (x >800){
cout << "Too much" << endl;
}
}
//complete the getter function
int getHorsepowers() {
return horsepowers;
}
};
int main() {
//getting input
int horsepowers;
cin >> horsepowers;
//creating the object of class Car
Car car;
//setting the value for private member
car.setHorsepowers(horsepowers);
//printing the value of private member
cout << car.getHorsepowers();
return 0;
}
+ 1
#include <iostream>
using namespace std;
//class definition
class Car{
//private area
private:
int horsepowers;
//public area
public:
//complete the setter function
void setHorsepowers(int x){
horsepowers = x;
if (x >800){
cout << "Too much" << endl;
}
}
//complete the getter function
int getHorsepowers() {
return horsepowers;
}
};
int main() {
//getting input
int horsepowers;
cin >> horsepowers;
//creating the object of class Car
Car car;
//setting the value for private member
car.setHorsepowers(horsepowers);
//printing the value of private member
cout << car.getHorsepowers();
return 0;
}
Good Luck
0
I slightly edited this code there were some mistakes but I solved them, so I think this is the solution.
public:
//complete the setter function
void setHorsepowers(int x){
horsepowers = x;
}
//printing the value of private member
if (car.getHorsepowers() >800) cout << "Too much" << endl;
cout << car.getHorsepowers();
0
Thanks SoloProg, unfortunately it still says “x not declared”
0
Thanks SoloProg, i retype the last 2nd line and it works. Thanks so much.
- 1
#include <iostream>
using namespace std;
//class definition
class Car{
//private area
private:
int horsepowers;
//public area
public:
//complete the setter function
void setHorsepowers(int x){
horsepowers = x;
if (x >950){
cout << "Too much" << endl;
}else{
return x;
}
}
//complete the getter function
int getHorsepowers() {
return horsepowers;
}
};
int main() {
//getting input
int horsepowers;
cin >> horsepowers;
//creating the object of class Car
Car car;
//setting the value for private member
car.setHorsepowers(horsepowers);
//printing the value of private member
cout << car.getHorsepowers();
return 0;
}