Boolean logic confused, please help me guys
Please look this question and help me to solve it, because i'm so confused to what this app want. Or it just me who didn't understand after all? I need to create a program that outputs whether a store is Open or Closed, based on the hour and the day of the week. The store is open on all days from 10 to 21, except Saturday and Sunday. I need to take the hour and the day of the week as input. The day of the week is represented as an integer (1 for Monday, 2 for Tuesday, etc.) Sample Input: 15 4 Sample Output: Open I try to answer those question with this: hour = int(input()) day = int(input()) if (day==1 and hour>=10 and hour<=21):print("Open") elif (day==2 and hour>=10 and hour<=21):print("Open") elif (day==3 and hour>=10 and hour<=21):print("Open") elif (day==4 and hour>=10 and hour<=21):print("Open") elif (day==5 and hour>=10 and hour<=21):print("Open") elif (day==6 or day==7):print("Closed") #why_it_still_wrong_???